Author Topic: 141c suddenly stopped working  (Read 5354 times)

0 Members and 1 Guest are viewing this topic.

Offline ctf58

  • Jr. Member
  • **
  • Joined: Aug 2011
  • location: Henderson Ky
  • Posts: 36
  • Unit(s): 570 DI
141c suddenly stopped working
« on: June 09, 2012, 08:47:00 PM »

Hello everyone. I have a Humminbird 141c and it has worked great until today. I was doing fine then the low voltage alarm beeped and the unit went off. The voltage was not low, I was running about 30mph on calm water and the voltage on my dash was reading 12.9 volts. Now if I press the power button I can here a faint power up beep followed by several fainter beeps, but no display at all. I moved my 570di to the dash mount and it did power up but the transducers are different so I could not use it. What sucked was that I was in unfamiliar waters and the 141c was my depth gauge. I had to go 6 miles just barley over idle and it took about 1 hour.

Any ideas what could have happened and is it fixable? Is there any kind of master reset?

Thanks in advance.
ctf58


Offline ctf58

  • Jr. Member
  • **
  • Joined: Aug 2011
  • location: Henderson Ky
  • Posts: 36
  • Unit(s): 570 DI
Re: 141c suddenly stopped working
« Reply #1 on: June 13, 2012, 08:08:12 AM »
Anyone got any advice? Is there a button press combo that will factory reset to see if it helps or a fuse inside or anything I can try. Or am I SOL on this unit?

Offline ITGEEK

  • Hero Member
  • *****
  • Joined: Aug 2009
  • location: Maryland
  • Posts: 1552
  • Unit(s): 1198c -Team Watters SS - Lexerd SP
  • Software: 7.670
  • Accessories: XM Weather - Weathersense
Re: 141c suddenly stopped working
« Reply #2 on: June 13, 2012, 08:23:35 AM »
I can suggest the following:
Your battery may be bad.  Do not assume it is good.
It doesn't matter if the voltage is adequate.  The battery can still be bad.

Fully charge it and load test it.
If you don't have a battery load tester, maybe track-auto or autozone can check it for you
for free.
If that is not possible, then hook the unit up to a battery you know that is good (like your car).

Check your power connections and fuse for tightness and corrosion.

The only reset I know of on humminbird models is resetting the custom settings to default.

Offline ctf58

  • Jr. Member
  • **
  • Joined: Aug 2011
  • location: Henderson Ky
  • Posts: 36
  • Unit(s): 570 DI
Re: 141c suddenly stopped working
« Reply #3 on: June 13, 2012, 11:04:07 AM »
Thanks for the reply ITGEEK.
The battery is good, it spins my 150hp Merc like a top and the other Hb 570di powered right up using the 141's mount and the display came on it. The 570di showed a voltage of 12.2 with the motor off and 13.2 with the motor running and the dash was showing about the same level. 
I asked about the button combo reset because there was another thread where it was advised to press the power+up&down buttons to "reset the unit". I guess this unit is dead. I'll take it apart and have a look around inside.
You know how it is, when it rains, it pours and my money has to go to other things before buying a fishfinder because other thing seem to breakdown that the wife thinks are more important.

Offline ITGEEK

  • Hero Member
  • *****
  • Joined: Aug 2009
  • location: Maryland
  • Posts: 1552
  • Unit(s): 1198c -Team Watters SS - Lexerd SP
  • Software: 7.670
  • Accessories: XM Weather - Weathersense
Re: 141c suddenly stopped working
« Reply #4 on: June 13, 2012, 11:34:06 AM »
It's good you're handy.  You might luck out and be able to fix it yourself.
Something may just be loose inside.
I'd do everything I could to fix it myself, before I shelled out coin to have it.
fixed, including smacking it with a big freaking rubber hammer.

My lady worries me about the freaking grass, while I'm thinking about
working on my boat.  Grass is like a cancer that never stops.
When I'm dead and buried, that freaking sh@t will still be growing.
People talk about boats being holes in the water that you keep throwing
money into.  At least with a boat, you have something tangible that
you can use.

Grass is a bottomless pit that you keep throwing money, time, and sweat into,
and in the end, you have absolutely nothing but more work to do.
If you're not careful, you can loose an eye or a limb trying to keep the
totally worthless crap at bay.

With all our technology, why can't someone develope a grass that only
grows one inch and stays that way.

That rant felt good. :)
« Last Edit: June 13, 2012, 11:35:18 AM by ITGEEK »

Offline sonar2000

  • Chief
  • Global Moderator
  • *
  • Joined: May 2009
  • location: Kerr Lake NC
  • Posts: 5970
  • It is not lost ...it has been misplaced.
  • Unit(s): (1) 1197 (1) 1198
  • Software: 6.6
  • Accessories: Tow Fish
Re: 141c suddenly stopped working
« Reply #5 on: June 13, 2012, 12:13:38 PM »
+ 100.  I hate grass...but I would rather cut than pull at the roots...
Now before we hijack the thread...

I i too recall some other posts here about butttons on the HB units.  I do believe there are some quality issuesw with them.
Not a lot but some of the guys have had to send in for repair..

Chuck

Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: 141c suddenly stopped working
« Reply #6 on: June 14, 2012, 07:56:52 AM »
I don’t think that this is related to the buttons.  The unit was working and shut off – no button was pressed to make this happen.  Sounds more like something inside failed.

Just remember that buttons/switches are a mechanical device and as such are more prone to failure than electrical devices are.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com

Offline ctf58

  • Jr. Member
  • **
  • Joined: Aug 2011
  • location: Henderson Ky
  • Posts: 36
  • Unit(s): 570 DI
Re: 141c suddenly stopped working
« Reply #7 on: June 14, 2012, 04:01:39 PM »
I did not mean a button was messed up. I meant on some devices  a buttom combonation acts as a code ro reset the units software and reboots it to factory settings. Such as on my cell phone I can power up hoding both volume up and down keys at the same time to do a system diagnostic without android loading. Sort of a safe mode. Thanks for the help.
ps I like to mow grass. I cannot hear the wife tell me what she wants done.


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
3491 Views
Last post October 10, 2009, 09:04:03 AM
by Humminbird_Greg
2 Replies
2152 Views
Last post August 22, 2012, 02:46:25 PM
by e1035
4 Replies
1668 Views
Last post July 10, 2013, 05:06:35 AM
by Humminbird_Greg
3 Replies
1355 Views
Last post November 19, 2014, 10:42:02 AM
by rnormanr
9 Replies
2094 Views
Last post October 31, 2015, 08:48:48 PM
by lake anna george
3 Replies
1173 Views
Last post July 03, 2017, 06:42:29 PM
by Bob B
1 Replies
422 Views
Last post July 19, 2018, 11:09:50 AM
by rnvinc
1 Replies
176 Views
Last post October 08, 2018, 07:37:03 PM
by rnvinc


SimplePortal 2.3.3 © 2008-2010, SimplePortal