Author Topic: Another broken transducer mount  (Read 2349 times)

0 Members and 1 Guest are viewing this topic.

Offline ElvisMarcy

  • Jr. Member
  • **
  • Joined: May 2010
  • location: United States
  • Posts: 20
  • Unit(s): shuchang
  • Software: windows
  • Accessories: XP
Another broken transducer mount
« on: November 01, 2010, 07:45:11 PM »
I have read a lot of post on three different web sites about this problem. Now I'm joining the complaint list. My mount broke they must have a flaw in the mount bracket. I'm running two units the 798Si, I also have the 777c2 both transducers are mounted on the transom. The 777 has been on the boat for 18 months no problems. The 798Si I would say 3 months & what happens next is anyones guess. I never hit anything, My Yamaha 60 four stroke would have a top speed 59km on my hull. I think Humminbird should look into re design the mount.
__________________________________________________
Ford shocks and struts
Toyota quick strut
Nissan quick strut
« Last Edit: November 03, 2010, 07:03:58 PM by ElvisMarcy »


Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: Another broken transducer mount
« Reply #1 on: November 02, 2010, 12:41:08 PM »
Call the Humminbird Customer resource folks up at 1-800-633-1468 and ask for a replacement mounting bracket (and transducer if that got damaged).  Both transducers you have should be using the same hardware.

Greg Walters at Humminbird
gwalters@johnsonoutdoors.com


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
2064 Views
Last post October 27, 2009, 11:23:43 AM
by Macca
1 Replies
4005 Views
Last post May 31, 2012, 09:07:47 PM
by Brian37075
12 Replies
7203 Views
Last post November 03, 2012, 08:03:11 PM
by Slip
5 Replies
2166 Views
Last post May 30, 2013, 02:14:51 PM
by RBrad
8 Replies
3852 Views
Last post February 19, 2014, 07:20:57 AM
by N9Phil
4 Replies
2035 Views
Last post March 19, 2016, 02:16:42 PM
by Rickard
6 Replies
1454 Views
Last post February 28, 2017, 09:45:29 PM
by Blove WI
3 Replies
753 Views
Last post July 27, 2017, 02:17:45 AM
by fishreed


SimplePortal 2.3.3 © 2008-2010, SimplePortal