Author Topic: Helix 10 SI screen unreadable  (Read 399 times)

0 Members and 1 Guest are viewing this topic.

Offline danj

  • Newbie
  • *
  • Joined: Aug 2018
  • location: Central Wisconsin
  • Posts: 4
  • Unit(s): Helix 10 SI
  • Software: 1.640
Helix 10 SI screen unreadable
« on: August 21, 2018, 11:32:27 AM »
Hoping someone can help! My Helix 10 will sometimes completely scrambles the screen, and is unusable. It can happen while in motion, or while sitting idle in calm water. It doesn't matter which view I'm in, navigation, split screen, DI, SI, or any other. It's not interference, as it will happen with no other electronics on, and will also appear sometimes with assecories on. Reset all settings, uploaded new basemap, and loaded latest update. Also installed brand new battery, without any change in the problem. Running Lakemaster chip, and Zeroline card. Tried to reset without cards in, and still no difference.
When it occurs, it will respond to keys, and can turn it off, but all  views are scrambled. It might works for 20 or 30 hours (over a few trips), and then will randomly occur out of no where. Wiggling the connector has no effect, so don't think it's a short. Humminbird has no idea, and it's 6 months out of warranty. Hoping I didn't waste $1699.00. See image of what the screen looks like.
« Last Edit: August 21, 2018, 11:34:34 AM by danj »


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3405
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 10 SI screen unreadable
« Reply #1 on: August 22, 2018, 04:53:44 AM »
Do have anyone close that you can crosstest your head unit on their boat  ...??

Rickie

Offline danj

  • Newbie
  • *
  • Joined: Aug 2018
  • location: Central Wisconsin
  • Posts: 4
  • Unit(s): Helix 10 SI
  • Software: 1.640
Re: Helix 10 SI screen unreadable
« Reply #2 on: August 22, 2018, 10:18:20 AM »
Unfortunately, no one nearby that I can swap with. Was installed by a dealer, so I assume it was installed correctly. Attached is an image of what it looks like when it acts up.

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3405
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 10 SI screen unreadable
« Reply #3 on: August 23, 2018, 05:28:19 AM »
You might try selecting "HB 83/200" in the Connected Transducer Menu under the Sonar tab and test on the water  ...

This setting shuts off the imaging transmitters  ... It may tell us something  ...

Rickie

Offline danj

  • Newbie
  • *
  • Joined: Aug 2018
  • location: Central Wisconsin
  • Posts: 4
  • Unit(s): Helix 10 SI
  • Software: 1.640
Re: Helix 10 SI screen unreadable
« Reply #4 on: September 15, 2018, 06:04:36 PM »
Thanks for the suggestion. Tried just the HB 83/200 setting on the transducer, and had the same results. Seems like the issue occurs within 10 minutes of starting the unit. Also tried restoring defaults again, but same results. Are you thinking this rules out a defective transducer?

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3405
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 10 SI screen unreadable
« Reply #5 on: September 16, 2018, 04:58:45 AM »
Thanks for the suggestion. Tried just the HB 83/200 setting on the transducer, and had the same results. Seems like the issue occurs within 10 minutes of starting the unit. Also tried restoring defaults again, but same results. Are you thinking this rules out a defective transducer?

I think you should call Humminbird  ...

1-800-633-1468

Rickie

Offline danj

  • Newbie
  • *
  • Joined: Aug 2018
  • location: Central Wisconsin
  • Posts: 4
  • Unit(s): Helix 10 SI
  • Software: 1.640
Re: Helix 10 SI screen unreadable
« Reply #6 on: September 17, 2018, 06:43:06 PM »
Yes, I have been in contact with Humminbird, but they have no solution. I've tried all of their suggestions, other than sending the entire unit in for $300, and no guarantee that there's an issue with the unit. They've have been very open about it possibly being electrical. But, I had it installed by the dealer. I'm trying to decide if I should try to replace the transducer myself for $200, or send the whole unit in for $300.

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3405
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 10 SI screen unreadable
« Reply #7 on: September 18, 2018, 08:22:35 AM »
You might think about bypassing the entire dealer wire circuit  ...

Trace the power wire from the the head unit to the 1st splice (should be 6ft from head unit)  ...and undo the spice  ...

Wire the factory 6ft HB cable direct to a battery sitting temporary at the unit location  ...(still use a fuse on the positive wire)  ... 

Test  ...

Many issues reported thru the electronics forums are narrowed down to that "reputable dealer" that used the factory boat harness wiring (usually too small and/or too many connections to carry adequate power to the unit)  ...

At least this test is free  ... just a little time involved  ...

Rickie
« Last Edit: September 18, 2018, 08:25:53 AM by rnvinc »


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
4 Replies
2279 Views
Last post February 10, 2011, 08:44:25 AM
by The bird
2 Replies
1318 Views
Last post December 31, 2014, 07:31:06 AM
by Humminbird_Greg
2 Replies
1508 Views
Last post July 09, 2015, 10:50:14 AM
by CATNIP
3 Replies
1425 Views
Last post November 08, 2015, 11:17:01 AM
by 95Ranger
1 Replies
1146 Views
Last post February 14, 2016, 12:26:33 PM
by N9Phil
3 Replies
1542 Views
Last post December 06, 2017, 07:23:34 PM
by rnvinc
1 Replies
523 Views
Last post July 13, 2017, 06:12:14 PM
by rnvinc
2 Replies
580 Views
Last post December 14, 2017, 03:42:25 PM
by bigkahuna


SimplePortal 2.3.3 © 2008-2010, SimplePortal