Author Topic: 898SI Lost GPS  (Read 1346 times)

0 Members and 1 Guest are viewing this topic.

Offline iceimanhunting

  • Newbie
  • *
  • Joined: Aug 2010
  • location: schenectady,n.y.
  • Posts: 3
  • Unit(s): 898c SI
  • Accessories: NONE
898SI Lost GPS
« on: July 18, 2013, 10:05:07 AM »
While fishing my G.P.S. speed and time started flashing and by going to menu I lost my G.P.S..I tried to restart the unit and unplug and repluged the wires on back of unit to no advail,even tried to reset defaults nothing worked.Call customer service and sent the unit and gps back to Hummingbird.The unit is 3yrs old and never had any trouble till this year.I am a Charter Capt and had to cancel charters,can't fish without the unit working.



Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1596 Views
Last post August 21, 2011, 06:30:43 PM
by RGecy
52 Replies
28515 Views
Last post July 26, 2014, 11:28:52 PM
by Hennessyt
15 Replies
4824 Views
Last post November 18, 2014, 02:01:51 PM
by Humminbird_Greg
6 Replies
1613 Views
Last post January 02, 2015, 06:31:54 AM
by Steve Schmidt
4 Replies
1171 Views
Last post June 11, 2015, 02:54:17 PM
by Beaulieu80
6 Replies
1986 Views
Last post February 26, 2016, 06:08:11 AM
by bobcoy
10 Replies
2622 Views
Last post June 11, 2017, 05:14:26 PM
by marknfish
2 Replies
642 Views
Last post August 14, 2018, 08:26:07 AM
by TroyBoy30


SimplePortal 2.3.3 © 2008-2010, SimplePortal