Author Topic: 598ci HD SI Firmware  (Read 1233 times)

0 Members and 1 Guest are viewing this topic.

Offline sje1149

  • Newbie
  • *
  • Joined: Apr 2017
  • location: Show Low, AZ
  • Posts: 5
  • Unit(s): 598ci HD SI
  • Software: 7.3
598ci HD SI Firmware
« on: April 18, 2017, 09:09:20 AM »
I purchased my 598ci HD SI in March 2013, can anyone advise what firmware the unit had when shipped new?   I never paid any attention and the unit worked great.   Since I updated to 7.3 it doesn't mark fish!   I haven't had much luck dealing with Humminbird support, and have tried restoring defaults etc.   Anyway would like to revert back to the original firmware from 2013, does anyone on the forum have that and can send to me?    Thanks!

Steve


Offline ckd022

  • Newbie
  • *
  • Joined: Feb 2014
  • location: Chicago, IL
  • Posts: 18
  • Unit(s): 798ci SI Combo
  • Software: 5.840
Re: 598ci HD SI Firmware
« Reply #1 on: April 18, 2017, 03:09:05 PM »
Steve,

I had exactly the same problem back in 2014 with my 798c after upgrading to version 6.3. I stopped seeing fish.  At first I thought it was me, or the settings, or that my lake just sucked.  Eventually I contacted Humminbird customer service via email at the time and they were able to tell me the version of software (and provide it to me) that my unit came with by looking up the serial number.  Their first answer was that they don't recommend downgrading due to the risk of "Bricking" the unit, but my response was that I understood the risk and was willing to take it on (as the unit was useless to me since it wasn't marking any fish).

Not that this helps you, but the version I downgraded to was 5.84, and I have stayed with it ever since.

Good Luck!
Kevin

Offline sje1149

  • Newbie
  • *
  • Joined: Apr 2017
  • location: Show Low, AZ
  • Posts: 5
  • Unit(s): 598ci HD SI
  • Software: 7.3
Re: 598ci HD SI Firmware
« Reply #2 on: April 18, 2017, 03:16:54 PM »
Thanks Kevin, I have been exchanging emails with support, not making much headway but we'll see.   I have asked for the download back to the original firmware, just waiting to hear back.

Steve

Offline ckd022

  • Newbie
  • *
  • Joined: Feb 2014
  • location: Chicago, IL
  • Posts: 18
  • Unit(s): 798ci SI Combo
  • Software: 5.840
Re: 598ci HD SI Firmware
« Reply #3 on: April 18, 2017, 03:22:24 PM »
Steve,

I can forward you the email chain I had with them back in the day if you want it.  Just PM you email address to me.  Hopefully they will resolve this for you.  I definitely learned my lesson - always have a copy of your original SW before upgrading!

Kevin

Offline sje1149

  • Newbie
  • *
  • Joined: Apr 2017
  • location: Show Low, AZ
  • Posts: 5
  • Unit(s): 598ci HD SI
  • Software: 7.3
Re: 598ci HD SI Firmware
« Reply #4 on: April 27, 2017, 08:15:16 AM »
Humminbird sent me the original firmware 6.460, all good!


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
5 Replies
3714 Views
Last post March 17, 2013, 07:40:37 AM
by dfdtr40
7 Replies
6803 Views
Last post December 22, 2012, 08:30:40 PM
by Rotus623
1 Replies
1565 Views
Last post February 18, 2013, 12:21:08 PM
by Humminbird_Greg
13 Replies
10463 Views
Last post March 22, 2013, 12:31:07 PM
by Humminbird_Greg
1 Replies
2922 Views
Last post January 07, 2014, 09:40:23 AM
by Humminbird_Greg
3 Replies
1640 Views
Last post April 11, 2014, 09:40:41 AM
by Humminbird_Greg
14 Replies
5766 Views
Last post April 25, 2014, 07:18:44 PM
by slabbacks
2 Replies
1062 Views
Last post June 16, 2014, 02:43:37 PM
by MadTownGator


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal