Author Topic: New helix 10 mega si, nothing working  (Read 620 times)

0 Members and 1 Guest are viewing this topic.

Offline Erics

  • Newbie
  • *
  • Joined: May 2019
  • Location: Wisconsin
  • Posts: 1
  • Unit(s): Helix 10, 9
  • Software: 1.6
New helix 10 mega si, nothing working
« on: May 28, 2019, 09:19:42 AM »
Purchased a new Helix 10 mega si. First the side scan wasn’t working correctly. Only horizontal lines/dashes on the screen. Called humminbird, sent me new transducer. Connected it, same thing. Humminbird said, do the update. I have. Now, my 2D, works sometimes. that’s after having to restart it several times. Most of the time, it’s 400ft deep, with jagged lines on the screen.

I’ve been with Lowrance for 25+ years. Switched over because a friend talked me into it, and seeing the side imaging. Now I feel it’s the biggest mistake I’ve made. I’m on hold right now with humminbird, as I type this.

Am I missing something? Anyone have any suggestions????P


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3709
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: New helix 10 mega si, nothing working
« Reply #1 on: May 29, 2019, 08:16:37 AM »
Restore Defaults under the Setup tab  ... Then power off the unit  ...

During power up (when the HB logo appears) press the Menu button to open an Xpress Menu  ...

Select "Normal" from the pop-up choices  ...

Report back here  ...

Rickie


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
2649 Views
Last post June 26, 2016, 09:07:35 AM
by Rpadar
1 Replies
3345 Views
Last post November 22, 2017, 09:10:21 PM
by rnvinc
0 Replies
3317 Views
Last post February 19, 2018, 08:24:42 PM
by Whistler
2 Replies
1682 Views
Last post April 02, 2018, 04:12:01 PM
by Rickard
3 Replies
3355 Views
Last post May 28, 2018, 09:28:20 AM
by rnvinc
3 Replies
1527 Views
Last post July 08, 2018, 07:55:55 PM
by rnvinc
5 Replies
1613 Views
Last post February 27, 2019, 08:06:55 PM
by Blacklab
6 Replies
2081 Views
Last post January 06, 2019, 02:05:37 PM
by rnvinc


SimplePortal 2.3.3 © 2008-2010, SimplePortal