Author Topic: Helix 10 left side imaging dark  (Read 182 times)

0 Members and 1 Guest are viewing this topic.

Offline toryweigel

  • Newbie
  • *
  • Joined: May 2017
  • Location: washington
  • Posts: 3
  • Unit(s): helix 10 si di g2n
Helix 10 left side imaging dark
« on: September 07, 2020, 07:54:35 PM »
My left side of side scan went dark.  Itís been fine for 2yrs and just stopped working. Tried another transducer and it didnít solve the problem.  Has this happened to anyone else? 


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3906
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 10 left side imaging dark
« Reply #1 on: September 07, 2020, 09:33:15 PM »
Transducers do go bad (or get weak) over time  ...

*Try Restore Defaults  ...
*Try removing the xducer, temporarily mount then ducer to a pole and stick it way down in the water (to test that nothing is blocking the beam  ...
*Try another head unit on your xducer to troubleshoot your xducer  ...

Call HB after all the above  ... 1-800-633-1468

Rickie


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
14 Replies
6913 Views
Last post February 01, 2010, 10:36:00 PM
by lcookie
19 Replies
11107 Views
Last post June 05, 2011, 09:21:26 PM
by Double Digit
17 Replies
9545 Views
Last post March 14, 2013, 04:37:52 PM
by Rickard
10 Replies
5527 Views
Last post March 12, 2013, 10:30:15 PM
by autopilot70
14 Replies
9118 Views
Last post June 17, 2014, 10:21:29 PM
by Time Out
6 Replies
6034 Views
Last post June 21, 2016, 11:33:31 AM
by Bob B
5 Replies
3681 Views
Last post December 04, 2017, 09:44:39 PM
by rnvinc
3 Replies
3906 Views
Last post May 30, 2018, 08:11:04 AM
by rnvinc


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal