Author Topic: Helix 5 SI Problems  (Read 350 times)

0 Members and 1 Guest are viewing this topic.

Offline Widariuskrucker

  • Newbie
  • *
  • Joined: Mar 2020
  • Location: Texas
  • Posts: 1
  • Unit(s): Helix 5 SI g2
Helix 5 SI Problems
« on: March 06, 2020, 11:21:46 PM »
I have been having problems with my new helix 5 si unit. I have the transducer transom mounted, i leveled it, it is directly wired to a deep cycle battery and I am still getting blurry, dark, unreadable images on my side and down scan. The only way to make the image bright is to max the sensitivity and drop the contrast down pretty low and even then you literally cannot make out anything. Could it just be a lemon transducer that I should get in contact with humminbird about? Any solutions would be appreciated
« Last Edit: March 07, 2020, 12:33:20 AM by Widariuskrucker »


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3877
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 5 SI Problems
« Reply #1 on: March 07, 2020, 01:01:12 AM »
Try Restore Defaults  ...

If that doesn’t help call HB  ...

1-800-633-1468

Rickie


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
5 Replies
4105 Views
Last post March 18, 2011, 09:02:06 AM
by maxflia
3 Replies
1877 Views
Last post April 09, 2017, 07:55:05 PM
by rnvinc
9 Replies
3578 Views
Last post August 04, 2017, 06:01:50 PM
by Big John
3 Replies
1907 Views
Last post September 28, 2017, 09:50:26 PM
by rnvinc
3 Replies
6054 Views
Last post May 28, 2018, 09:28:20 AM
by rnvinc
3 Replies
3156 Views
Last post July 08, 2018, 07:55:55 PM
by rnvinc
4 Replies
1579 Views
Last post September 07, 2018, 02:25:53 PM
by steelebob
6 Replies
1881 Views
Last post May 27, 2020, 08:59:54 AM
by rkeller


SimplePortal 2.3.3 © 2008-2010, SimplePortal