Author Topic: 360 mega problems  (Read 776 times)

0 Members and 1 Guest are viewing this topic.

Offline big train

  • Newbie
  • *
  • Joined: Nov 2011
  • Location: s.c.
  • Posts: 3
  • Unit(s): Helix 10’s gen3
  • Accessories: Mega 360
360 mega problems
« on: March 02, 2020, 11:01:38 AM »
New 360 mega first time out. It reads 360 out of water and does not work. Then towards the end of the day it works for a second. Then quits. Smh anyone else experienced this?
Confidence is Key


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3902
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: 360 mega problems
« Reply #1 on: March 04, 2020, 11:05:50 AM »
Have you updated the MEGA 360  ...??

The newest update addresses some wet switch problems  ...

Software Update - MEGA 360 Imaging
v. 1.070 for HELIX G3N

Released 2/24/2020

Software Description

PLEASE NOTE:

  • This MEGA 360 software is only compatible with HELIX G3N Imaging+ models.
  • HELIX must be running v2.180 or newer software to install v1.070 software on the MEGA 360.

Affected Models:


  • 411250-1 – MEGA 360 ULTREX
  • 411260-1 – MEGA 360 FORTREX
  • 411390-1 – MEGA 360 UNIVERSAL

Summary of issues that have been addressed in v1.060:


  • Improved performance of the MEGA 360 wet-switch.

Rickie
« Last Edit: March 04, 2020, 11:07:12 AM by rnvinc »

Offline big train

  • Newbie
  • *
  • Joined: Nov 2011
  • Location: s.c.
  • Posts: 3
  • Unit(s): Helix 10’s gen3
  • Accessories: Mega 360
Re: 360 mega problems
« Reply #2 on: March 04, 2020, 12:00:08 PM »
Has been updated now it’s showing mega 360 not detected and not working it all 🤨
Confidence is Key

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3902
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: 360 mega problems
« Reply #3 on: March 05, 2020, 12:05:27 PM »
Is the unit also on the latest update  ...?? (HB will ask the same question)  ...   

Try Restore Defaults  ...

If that doesn’t work call HB  ...

1-800-633-1468

Rickie
« Last Edit: March 05, 2020, 12:06:53 PM by rnvinc »


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
5462 Views
Last post November 22, 2017, 09:10:21 PM
by rnvinc
2 Replies
2377 Views
Last post April 02, 2018, 04:12:01 PM
by Rickard
4 Replies
1718 Views
Last post September 07, 2018, 02:25:53 PM
by steelebob
0 Replies
4275 Views
Last post September 16, 2018, 03:15:09 AM
by cade
5 Replies
2576 Views
Last post February 27, 2019, 08:06:55 PM
by Blacklab
6 Replies
4823 Views
Last post January 06, 2019, 02:05:37 PM
by rnvinc
8 Replies
2297 Views
Last post October 08, 2019, 10:57:37 PM
by Blacklab
9 Replies
946 Views
Last post July 27, 2020, 09:28:36 AM
by emerles


SimplePortal 2.3.3 © 2008-2010, SimplePortal