Author Topic: Solix Chirp Mega G2 / Link Controls Issues  (Read 794 times)

0 Members and 1 Guest are viewing this topic.

Offline DennyO

  • Jr. Member
  • **
  • Joined: Sep 2011
  • Location: Iowa, USA
  • Posts: 23
  • Unit(s): Ulterra Link Solix 15 & 12 G2 5 pin Hub
  • Software: 3.40
  • Accessories: Softw2.14 L, 2.04R
Solix Chirp Mega G2 / Link Controls Issues
« on: May 20, 2019, 08:30:08 PM »
I own one each, newly released this spring Solix 15 & 12 Chirp Mega SI G2's, 12" on the bow & 15" on the consol, each with software ver# 3.400 (rev 3-22-2019)
Split L & R SI ducers using the Y cable and also a high speed ducer with it's splitter Y cable.
Ulterra I-Pilot Link 112# gen1,
Link Remote Software 2.040 (rev 11-21-2014)
Link Controller Software 2.150 (rev. 3-19-2015)
5 port hub
Lake Master Link version map cards
Midwest, Great Plains, Dakotas, Minn, Rainey / LOW, Wisc, Great Lakes
and others that we before the link came about.

I had my first outing with my birds on a local water reservoir this past week. The Pics on the Birds is AWESOME! I will be using SI most often from now on period along with the mapping cards. Never losing depth. SI, DI and 2d Very Pleased @ less than 10 mph! I've got a little SI ducer adjustments to make, no issue.

I've been watching Doug's all of the ones that when using the search function, include "Solix, Solix G2, Link, I-Pilot Link". They are very helpful to familiarize me with my new units after removing my old Core 1198 & 998 that I installed right after they first came out.

Just thought that I would include a bit of an intro to help in your suggestions to resolve my issue. I will not be available very much in the next 8 days as I will be out of the country on a family fisit. My internet will be extremely limited. When I return I'll be about 6 days before I go to Lake Oahe for a week. I use the Link a ton there.

My issue,
Link is not functioning, by that I mean

I can from my birds Link window, stow and deploy but that's about it.
I cannot, power the prop (actually I think that I could turn the button yellow and white but nothing more), alter speed, trim up or down, follow contour, steer left or right, and past that I don't remember.

The Remote still works just fine and full functioning. I have no idea if the pedal works as I've never hooked it up and it does not ride in the boat any more. Or maybe I have it hidden under the rear deck, heck I don't remember.

As I said, I will be limited on my phone while out of the country for a bit over a week.

Thanks Much!
Denny O
The Eyes have it! Hooking walleyes & watching Hawkeyes.


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3691
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Solix Chirp Mega G2 / Link Controls Issues
« Reply #1 on: May 20, 2019, 08:42:40 PM »
You might try simplifying your setup down to the iLink connected directly to 1 unit and test  ...

And then try connecting iLink directly to the other unit  ...

This may help narrow down the possibilities  ...

And HB customer service is always a great resource  ...

1-800-633-1468

Rickie

Offline DennyO

  • Jr. Member
  • **
  • Joined: Sep 2011
  • Location: Iowa, USA
  • Posts: 23
  • Unit(s): Ulterra Link Solix 15 & 12 G2 5 pin Hub
  • Software: 3.40
  • Accessories: Softw2.14 L, 2.04R
Re: Solix Chirp Mega G2 / Link Controls Issues
« Reply #2 on: May 20, 2019, 10:35:12 PM »
Thanks Rickie for the thoughts.

I know when I first received the two birds they were both on the previous software version. I before I ever hooked them up to the 5 port hub, I updated the software individually. then I connected the hub to the two of them. Turned on the Ulterra to verify the softwares according to the remote (which verified my notes  on my computer) so I plugged it into the 5 port then saw that the I-Pilot was connected according to the screen. At that point I shut it all down.

Waited a few minutes and fired up the dash, waited for it, then turned on the bow and waited for it then the ulterra. I was asked if I wanted to sync them, knowing that the latest softwares were installed I said yes. I went to the water for an hour or two and found that I had the problem. Got back home did some more research in to the settings and if I followed the comments that I had learned I proceeded to look into all the settings hoping to find some things that were unchecked last week, I didn't find an issue other than what I had stated.

So my testing will have to wait till I return from British Columbia.
The Eyes have it! Hooking walleyes & watching Hawkeyes.

Offline FishinLite

  • Jr. Member
  • **
  • Joined: Oct 2017
  • Location: Crosslake, MN
  • Posts: 32
  • Unit(s): 9 SI, 9 DI, AS ETH5PXG, I-Link, 360
  • Software: 7.765
  • Accessories: HD Side Imaging Transducer
Re: Solix Chirp Mega G2 / Link Controls Issues
« Reply #3 on: May 21, 2019, 09:36:25 AM »
I know from experience none of the iLink functions are available until the trolling motor is deployed.

For follow the contour to work you need to zoom in on your iLink map. 

I have 2 helix's a hub and a link trolling motor.

You might want to order Jason Halfen's Total Boat Control with Ipilot DVD. A little boring to watch but covers a lot of ground including Solix.

Good Luck .... Fish On

Offline DennyO

  • Jr. Member
  • **
  • Joined: Sep 2011
  • Location: Iowa, USA
  • Posts: 23
  • Unit(s): Ulterra Link Solix 15 & 12 G2 5 pin Hub
  • Software: 3.40
  • Accessories: Softw2.14 L, 2.04R
Re: Solix Chirp Mega G2 / Link Controls Issues
« Reply #4 on: May 27, 2019, 02:03:21 AM »
FishinLite, thank you for your help. I understand your guidance. I am well connected with Jason and Doug. My issues I think go beyond the entry level position.

Can anyone confirm that the Ulterra G1 and the Solix G2 are not compatible for the Link functions?
What I'm hearing is after 2015 documents and updates that I must purchase a $4100. Ulterra now after spending over $7000 to achieve the same level of electronic control that I had with the core series on my previous set up.

Someone please tell me that I've been miss lead.

I'm still out of the country so I can not call HB direct.
The Eyes have it! Hooking walleyes & watching Hawkeyes.

Offline DennyO

  • Jr. Member
  • **
  • Joined: Sep 2011
  • Location: Iowa, USA
  • Posts: 23
  • Unit(s): Ulterra Link Solix 15 & 12 G2 5 pin Hub
  • Software: 3.40
  • Accessories: Softw2.14 L, 2.04R
Re: Solix Chirp Mega G2 / Link Controls Issues
« Reply #5 on: June 05, 2019, 07:24:07 PM »
Hopefully a final update (if all works after I install the plug and play parts!) Maybe bobcoy and Wayne was somewhat on the right track, but was not pointing me towards the real answer. Still very helpful!! Many thanks Guys!!


Phoned Humminbird customer support last monday late afternoon. They wanted me to seperate the units and cable direct to the trolling motor one on one to isolate the issue if possible. And do so when I was on the water to test and be able to call them back while in the boat.
I haven’t been on the water yet but in my driveway late this afternoon there was no change when doing what HB and one of the other sites suggested about a controlled separation, so I called Minnkota.

The man @ Minnkota was very nice to speak with easy to understand and seemed to me that even though he could have been somewhat new, he still was following his own thought process as opposed to reading a predetermined resource manuel to do step by step try this and did that resolve Y/N like the graft companies do. The man gave me bad news after running it buy his fellow workers, incompatible and requires the new technology of the new motor , Damm! $3233.00 with tax, for a new one!! Wow that made my day. NOT! I’d rather wait till after I-Cast 2019 to see what will be heading our way first!
HE stalled just a touch and said, “There is one option, there is an upgrade kit that is available only for your Ulterra that will bring it up to the new Bluetooth I-Pilot Link w/US2 unit with a the new touch screen remote $820 w/ tax customer pickup @ Mankato, MN.” He double LL YES! I only won't get the MDI ducer of the new units If I'd buy the latest one.  He went on to state that since the Solix was so advanced and it’s software does not look back prior to bluetooth in the Gen 2 series, is the reason for the issue with the link. He also stated that No other trolling motor in the Minnkota line has this as an option. All others need a new motor (I assume within freshwater series but I don’t know).
I will keep this posted if there is any other adverse changes that requires an update. As it seems the issues are very specific to the old Ulterras and the new Solix Mega Gen 2's because of Bluetooth.
« Last Edit: June 05, 2019, 08:28:17 PM by DennyO »
The Eyes have it! Hooking walleyes & watching Hawkeyes.


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
10 Replies
5793 Views
Last post August 30, 2017, 09:10:38 PM
by fshndude
5 Replies
5515 Views
Last post October 04, 2017, 06:33:17 PM
by Stumpy
2 Replies
3087 Views
Last post September 30, 2017, 03:23:35 AM
by Rüdiger
10 Replies
4327 Views
Last post April 26, 2018, 08:35:22 PM
by rnvinc
6 Replies
3618 Views
Last post March 26, 2018, 09:48:08 PM
by rnvinc
1 Replies
531 Views
Last post March 05, 2019, 08:30:40 AM
by rnvinc
3 Replies
881 Views
Last post May 02, 2019, 12:26:32 PM
by abraquelebout
4 Replies
167 Views
Last post September 14, 2019, 12:23:02 AM
by rnvinc


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal