Author Topic: Couple of issues with connections on 998 HD  (Read 2137 times)

0 Members and 1 Guest are viewing this topic.

Offline CHOOhonets

  • Jr. Member
  • **
  • Joined: Oct 2010
  • Posts: 57
  • Unit(s): 998 HD SI
  • Software: 6.49
  • Accessories: AS SI LR Y cable
Couple of issues with connections on 998 HD
« on: November 11, 2013, 12:50:23 PM »
Hi guys, I have a couple of questions about my 998 HD:
1) My power cable started to disconnect from the head unit without any sufficient impact. I can not see a significant play or something, but the unit started to turn off frequently when I touch the cable. Seems like the problem is in connection play, because the cable doesn't look damaged. I actually found it out at home when I was exporting my waypoints. Don't know how it will work on boat, but seems like it will cause some problems and it might turn out really bad if I decide to upgrade unit software and it will turn off at that moment :-X
The question is if I should order one more power cable just to try or if there are some solutions helping to fix the cable rigidly?
2) Another question is if I should I do some preventative maintenance of the unit connectors. One guy's unit started working really bad when his connections got rusty. Check out the photo.
Thanks a lot in advance!
« Last Edit: November 11, 2013, 12:52:26 PM by CHOOhonets »


Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • Location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: Couple of issues with connections on 998 HD
« Reply #1 on: November 12, 2013, 10:55:45 AM »
So your unit was not on the boat when you were exporting your waypoints?  Without the connector collector helping hold the power connector in place there could be more play in the connection than there normally should be.  I would try to gently bend the gold pins of the power cable away from each other.  Bend them very slightly as all you are doing is increasing the contact resistance between the pin of the power cable and the socket of the unit connector.

If you are using your unit is a salt water environment I would flush the connectors with fresh water after use.  They are gold plated to resist corrosion.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
4286 Views
Last post September 18, 2010, 04:02:05 PM
by tierce2008
4 Replies
4735 Views
Last post February 07, 2011, 11:20:42 AM
by Kimi
2 Replies
11085 Views
Last post May 18, 2011, 03:12:23 PM
by fishinphil
10 Replies
6117 Views
Last post August 16, 2011, 02:36:10 PM
by ITGEEK
6 Replies
3749 Views
Last post March 04, 2012, 10:00:45 PM
by oz
14 Replies
8150 Views
Last post December 19, 2012, 05:08:26 PM
by strawdg
3 Replies
5044 Views
Last post March 15, 2013, 11:53:28 AM
by Humminbird_Greg
1 Replies
1944 Views
Last post July 04, 2016, 11:11:26 PM
by rnvinc


SimplePortal 2.3.3 © 2008-2010, SimplePortal