Author Topic: 998c SI Software Update Problems  (Read 4264 times)

0 Members and 1 Guest are viewing this topic.

Offline Ranger 354V

  • Newbie
  • *
  • Joined: Apr 2015
  • Location: Orange Park, Florida
  • Posts: 5
  • Unit(s): 898c SI, 989c SI
  • Software: 7.510
  • Accessories: standard GPS, and transducer
998c SI Software Update Problems
« on: April 15, 2015, 09:23:20 AM »
Hello everyone new to forum. I have a problem and the guys at Bass Boat Central (BBC) pointed me in this direction for help.

Here goes:

I have a 998c SI,  I got used from my BIL when he upgraded to a 1100 series unit.
He had never updated the software while he had it. It still had the original 4.xxx version software from 2010.

I bought a Navionics Hotmaps Platinum card and the directions with the card said to make sure you had the latest version of software for you unit before using the card. This is where the problem starts!

I went to the hummingbird site and registered the unit and downloaded the current software for my 998c SI unit version 7.510.
I copied it to a new blank formatted SD card.
Powered up unit and reset defaults powered unit down.
Powered up unit and did a complete and normal startup, I inserted the SD card with update on it.
Unit went through update normally upon completion I got the update was successful message.

But it was not I lost all of my chart views.

If I scroll through the views I get all of the sonar chart but no navigation charts. On the NAV menu tab all I get is the ability to select the GPS input, Auto or external.
I can bring up the GPS system check view and I can see all the satellites and the position read out so the units GPS is working. But no charts.
Now if you sit there, after a few minutes the with the NAV menu displayed all of a sudden the complete drop down menu will pop up in maybe 5 or 10 minutes. Then I was able to scroll through different views going through all the sonar views, then I would get to the chart in the 360 deg.  view (the one that looks like you are sitting in the boat and a compass is in the horizon) , as soon as I press the view button one more time to go what should be the normal chart view (the one that looks like a map) the unit will shutdown and restart. After restarting I bring up the main menu and go to the NAV tab and again I only have the one choice about the GPS I stated above wait 5 to 10 minutes and repeat the above cycle.

I have been on the phone with Humminbird (for 45 minutes) and the only thing she kept asking about was the GPS puck. I told her there is not problem with it since I can hook up my friends 898c SI to the same cables and everything works. I told her this was a software problem since the unit worked perfectly before the update to version 7.510. She finally put me on hold to talk to someone else and then she sent me an older version of the software 7.1xx (don't have unit in from of me) I copied the 7.1xx update to a blank SD card and installed it and replaced the 7.510 version software but I am still having the same problem.

I asked her if this could have happened because I went from the original 4.xxx version software straight to the 7.510 version with out any of the updates in between. She did not seem to think so.

So that is where I am right now. Humminbird told me its a $290.00 flat fee if I send it back to them. I don't think that is fair since the unit was working fine before installing their software update. If I should have done a progressive update to build up to version 7.510 they should have included that in the instructions.

Now here is my thoughts. If the unit worked fine with the original version of software 4.xxx should I download that version from the download section of the forum and replace the software on my unit with the original software since I had no problems with that version.
Or is it to late for that?

Thanks for any and all inputs.

Ranger 354V (Joe)


Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • Location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: 998c SI Software Update Problems
« Reply #1 on: April 15, 2015, 09:56:54 AM »
Joe,
First thing I would try would be to restore the menus back to the factory defaults.  I know you did this before installing the update but try it again afterwards.

If that does not help I would perform a Format Nav Directories function (look under the Setup menu tab).  You would first need to export your Nav Data (waypoints, routes and tracks) before doing this.  We have seen where newer software versions will not work with what end up being corrupt waypoints and this is especially true when loading a software version that adds waypoint management.  If that works, than you will need to use HumminbirdPC and look at each waypoint to see if you see anything out of place; like a waypoint made in the 1960's or something out of place like that.  Remove the corrupt waypoint and load the Nav Data into your unit again to see if it works or not.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com

Offline Ranger 354V

  • Newbie
  • *
  • Joined: Apr 2015
  • Location: Orange Park, Florida
  • Posts: 5
  • Unit(s): 898c SI, 989c SI
  • Software: 7.510
  • Accessories: standard GPS, and transducer
Re: 998c SI Software Update Problems
« Reply #2 on: April 15, 2015, 10:58:32 AM »
Thanks for the reply I will try doing what you said when I get home tonight and post results.
Thank for the quick reply
Joe

ETA: I just talked to my BIL and he has everything on the unit backed up already. So when I get home tonight I'll format  the NAV Directories and see what that does.
Thanks again for the help.
 
« Last Edit: April 15, 2015, 11:53:14 AM by Ranger 354V »

Offline Ranger 354V

  • Newbie
  • *
  • Joined: Apr 2015
  • Location: Orange Park, Florida
  • Posts: 5
  • Unit(s): 898c SI, 989c SI
  • Software: 7.510
  • Accessories: standard GPS, and transducer
Re: 998c SI Software Update Problems
« Reply #3 on: April 15, 2015, 06:01:32 PM »
Greg,
You are a life saver!!!! You instruction were spot on. Did what you said  restored defaults, formatted Nav directories and unit is working perfectly. Thank you for the help and saving me $290.00 by having to send unit back to Humminbird. Now I can reload the current software and be set.

Thanks again,
Joe

Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • Location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: 998c SI Software Update Problems
« Reply #4 on: April 16, 2015, 08:56:47 AM »
That's great news Joe.
Just be careful and look through those waypoints from your BIL if you are planning on loading them again.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
15 Replies
13697 Views
Last post June 16, 2010, 11:11:39 AM
by sonar2000
0 Replies
3915 Views
Last post April 05, 2010, 07:12:09 PM
by RGecy
6 Replies
10178 Views
Last post June 14, 2010, 11:05:10 PM
by RGecy
8 Replies
5595 Views
Last post March 12, 2013, 11:58:26 AM
by Humminbird_Greg
9 Replies
4831 Views
Last post January 06, 2015, 12:24:57 AM
by Thecatman
36 Replies
11390 Views
Last post May 04, 2016, 05:23:47 PM
by Bassman13579
8 Replies
4258 Views
Last post August 03, 2020, 12:27:59 PM
by ezfishn
2 Replies
1602 Views
Last post August 16, 2020, 02:37:18 AM
by ptgomes


SimplePortal 2.3.3 © 2008-2010, SimplePortal