Author Topic: Loss of detail with screen  (Read 3170 times)

0 Members and 1 Guest are viewing this topic.

Offline Dlc1978

  • Newbie
  • *
  • Joined: Oct 2016
  • Location: MI - Michigan
  • Posts: 4
  • Unit(s): 898
  • Software: 7.670
Loss of detail with screen
« on: April 21, 2019, 07:36:26 PM »
I am trying to troubleshoot my 898c. About 2 yrs ago the details quality really dropped off.  Picture is really blocky or pixelated.  I updated it, reset factory settings but made no difference.  I see the 898 is on Humminbirds will not repair list.  So I'm trying to decide if the problem is in the unit or transducer.   Is there a way to troubleshoot the transducer without buying a new one first.   Looking for any help I can get getting the sharpness of my image back. 


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 4338
  • Unit(s): 1197c SI Combo, SOLIX G2 MSI
  • Software: Dependent on whim
  • Accessories: AS GRHA, MEGA 360, LowBird LSS 1 & 2
Re: Loss of detail with screen
« Reply #1 on: April 22, 2019, 10:59:40 PM »
Transducers do wear over time  ...

The only way to test is with another transducer  ...

Rickie


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
17 Replies
18900 Views
Last post August 09, 2009, 07:57:17 AM
by Mental
1 Replies
3641 Views
Last post April 30, 2011, 10:21:17 AM
by thunderbucket
26 Replies
13236 Views
Last post September 17, 2017, 05:08:10 AM
by abraquelebout
6 Replies
6944 Views
Last post March 26, 2012, 08:36:33 PM
by Jim Gautney
10 Replies
6528 Views
Last post January 28, 2014, 10:38:41 AM
by Humminbird_Greg
2 Replies
3362 Views
Last post September 16, 2013, 07:33:41 PM
by Alloutdoors
1 Replies
3395 Views
Last post February 21, 2014, 09:28:43 AM
by TroyBoy30
6 Replies
4059 Views
Last post September 22, 2014, 12:03:15 PM
by Humminbird_Greg


SimplePortal 2.3.3 © 2008-2010, SimplePortal