Other Humminbird Products > Matrix Series Fishing Systems

Need help with Matrix97: GPS and update problems

(1/3) > >>

I inherited an old fishing boat with a Matrix97 GPS/fishfinder and GR4 puck (e.v. very old).  The GPS stopped working soon after my taking over the boat.  Sonar works fine.  When I run a system test on the startup screen, the GPS shows as “not connected.”

I’ve double checked the connections in the back of the unit – very solid.  No corrosion showing.
Voltage in the powercable at the pins is +12V by multimeter, although the Matrix97 shows it to be 11.2 volts on system test.
I connected it directly to a separate battery – same result: +12V by multimeter and 11.2V reported by Matrix97.
I checked the pigtail on the GPS cable:  +11V between the red and black wires (e.g. 1 volt drop in this output compared to the voltage into the Matrix97 as measured at the powercord).
I’ve restored defaults à no effect.
I purchased 2 MMC cards (8MB) and downloaded the update file from myhumminbird.  (These MMC cards are hard to find these days.)  The latest software version for  Matrix 97 is Version 4.750; Release Date: 01/14/2010.  The file I downloaded is entitled, “0bee626c78544848909f28c6b364bd96 (1).bin”  I used HumminbirdPC to put this file onto one of the 8MB MMC cards, and I used my Windows 7 PC to put this same software on the other MMC card.  When I put either of these MMC cards into the MMC slot in the Matrix97, the unit does not automatically update.  It does not matter whether I put it into the slot after the unit is powered on, or before it is powered on, or whether the unit is in “system test” or ”simulator” or “normal mode.”  And no dialogue box comes up indicating the unit recognizes the card/software.  And the menu button does not provide any option for “update software.”  I did use the menu button to “restore defaults.” I don’t have an AS-PC3 cable. They are about $50 on line.

For the possibility that the voltage out to the GPS is inadequate, I checked the voltage at the hole for pin 1 in the back of the Matrix 97.  It reads 10.8 volts (although keep in mind that the power in reads 11.2 even though power in at the cable is +12V).  So I carefully opened up that cable just before it enters the puck, and divided the red (power) wire to supply true +12V to the puck from a separate battery (grounded to black).  GPS still doesn’t show up as connected on the Matrix97.

It is frustrating to not be able to update the software to see if this could fix the problem (though deep down, I don’t think this is likely).  Does anyone have any clues why I am unable to update the software via the MMC card?   And as mentioned, I don’t have an AS-PC3 cable.

I could replace the puck with a GR16 for ~$125 – but if this doesn’t fix the problem, I’ve probably wasted another ~$125 since the GR16 puck seems outdated and not used on current Humminbird units.  Do these pucks go bad frequently? 

If I can’t fix this one, since all of the components are old it seems that I would have to purchase new head unit and new GPS puck, new transducers, new Navionics data cards; and then re-run cable for the new transducers, etc.  At lot of $$ and time. Or, can you recommend one that is currently available that would be backwards compatible with any of this existing old equipment (e.g. the transducers or Navionics data on MMC cards)? 

I do appreciate your time reading through  my note in hopes of providing help. Thank you.

Bob B:
If you are reading 11.2V on the unit, you have a bad connection somewhere that is causing voltage drop under load.....could be the power connector on the back of the unit, or somewhere else in the wiring.  GPS is one of the first things affected by low power.

Thanks, Bob B.  The boat is sending 12V to the Matix97 head unit:

Voltage in the powercable in to the Matrix97 at the pins is 12V by multimeter.  However, despite this the Matrix97 reports a voltage of 11.2 volts on system test.  And even when I connected the Matrix97 directly to a separate battery I observe the same result: 12V input as measured by by multimeter, but only 11.2V reported by Matrix97.  Seems to me that the multimeter is the gold standard -- is it meaningful that the Matrix97 reports 11.2 volts when the input is actually 12V?  Does this mean that the unit indeed is shot?  And a few other questions as mentioned below.  THank you.

Bob B:
Did you measure the voltage with the power cable unplugged from the unit ..... or plugged into the unit with the unit powered on?

Even if the voltage is checked external to the unit at the power plug with the unit powered on, if there is a bad connection at the power cord into the unit, you can still get voltage drop at the plug..... The unit is telling you you it is getting low voltage.

I checked the voltage in the power cable with the cable NOT plugged into the unit (and read the multimeter reads 12V).  How can I check the voltage in the power cable with the cable already plugged into the head unit?  With the cable plugged in, there is no immediate access to the pins in the cable.  I suppose I can open up the back of the unit and have access to the pins that come into the unit even when the power cable is plugged in.  Is that your suggestion?  Again, thank you very much.


[0] Message Index

[#] Next page

Go to full version