Author Topic: During loading recording data into Humviewer, some error occurs.  (Read 290 times)

0 Members and 1 Guest are viewing this topic.

Offline Mc Cloud

  • Newbie
  • *
  • Joined: Feb 2017
  • location: Seoul, Korea
  • Posts: 3
  • do you think that is the air, you're breathing now
  • Unit(s): Helix 10 mega si
  • Software: 1.350
  • Accessories: AS GPS HS
During loading recording data into Humviewer, some error occurs.
« on: September 18, 2017, 01:50:46 AM »
I tried to check the recording data in Hum Viewer.

When I open the recording file with Hum Viewer, it seems ok
Loading B000.SON
Loading B001.SON
Loading B002.SON
Loading B003.SON

But, at the turn of B004.SON, error occurs.

"This is not a valid Humminbird Sonar recording file.
 Cannot find type for file : B004.SON"

Has anyone experience this error?

My device is Helix10 Mega SI G2N.


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3088
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: During loading recording data into Humviewer, some error occurs.
« Reply #1 on: September 18, 2017, 06:39:29 AM »
Please find the actual recording folder on your PC  ... It should be listed as something like "R000x" and located in the "RECORD" folder on the SD card that was in the HB unit when the Recording was made  ...

Please list the files located in the "R000x" folder  ... and list the kb size of each file  ...

I think the B0004.SON is the GPS data from the Recording and maybe it is corrupt somehow  ...

Rickie

Offline ckd022

  • Newbie
  • *
  • Joined: Feb 2014
  • location: Chicago, IL
  • Posts: 18
  • Unit(s): 798ci SI Combo
  • Software: 5.840
Re: During loading recording data into Humviewer, some error occurs.
« Reply #2 on: September 18, 2017, 05:26:16 PM »
When I was decoding the SON files back in the day (I have a 798ci SI Combo), I only ever saw 3 SON files: B000 was the 50/83khz, B001 was the 200khz, B002 was the Port SI, B003 was the Starboard SI.  Maybe B004 is the Down Image?  If it is, I didn't have down imaging so I would have never run across that particular file.

If B004 seems corrupted, try renaming the B004.IDX and B004.SON files to TEMP.IDX and TEMP.SON then re-loading the DAT file.  I'm guessing that Humviewer will just start after loading B000 through B003, but you will lose whatever imaging data was stored in B004.

Kevin

Offline Mc Cloud

  • Newbie
  • *
  • Joined: Feb 2017
  • location: Seoul, Korea
  • Posts: 3
  • do you think that is the air, you're breathing now
  • Unit(s): Helix 10 mega si
  • Software: 1.350
  • Accessories: AS GPS HS
Re: During loading recording data into Humviewer, some error occurs.
« Reply #3 on: September 19, 2017, 01:18:11 AM »
When I was decoding the SON files back in the day (I have a 798ci SI Combo), I only ever saw 3 SON files: B000 was the 50/83khz, B001 was the 200khz, B002 was the Port SI, B003 was the Starboard SI.  Maybe B004 is the Down Image?  If it is, I didn't have down imaging so I would have never run across that particular file.

If B004 seems corrupted, try renaming the B004.IDX and B004.SON files to TEMP.IDX and TEMP.SON then re-loading the DAT file.  I'm guessing that Humviewer will just start after loading B000 through B003, but you will lose whatever imaging data was stored in B004.

Kevin

Thank for your help.
I removed the B004, No error occurs.
The B004 is not for DI, I can get DI replay.

Thx.

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3088
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: During loading recording data into Humviewer, some error occurs.
« Reply #4 on: September 19, 2017, 06:38:29 AM »
Thank for your help.
I removed the B004, No error occurs.
The B004 is not for DI, I can get DI replay.

Thx.

The HB core series units do not have a dedicated DI channel transmitting to a DI piezo in the SI xducer  ...

The DI image is computer generated from the SI data into a format that "looks" like DI  ...

Therefore, there will be no SON file for DI (in the HB core series SI units)  ...

Rickie

Offline ckd022

  • Newbie
  • *
  • Joined: Feb 2014
  • location: Chicago, IL
  • Posts: 18
  • Unit(s): 798ci SI Combo
  • Software: 5.840
Re: During loading recording data into Humviewer, some error occurs.
« Reply #5 on: September 19, 2017, 07:37:13 AM »
Rickie,

I knew that was the case with my 798, I just wasn't aware of the capabilities of the new Helix units.  It has been such a long time since I looked at this, but I think I already knew if you have a DI unit, then the B002 file is the down imaging data. 

In fact, I don't believe Humviewer "creates" the down image from the two SI images the way the sonar units do, it just takes the data in B002 "rotates it" to look like down imaging, and if you have an SI unit, it displays the port SI data as the DI image.

It would be interesting to know what is stored in the B004 file and even to see one.  I wonder if they changed the format of the completely or if they just gave it a different header to differentiate it from the older file types.  Humviewer hasn't been updated in such a long time I can see where it might not understand some of the newer sonar files that the new sonar units are creating now.

Kevin

Offline Mc Cloud

  • Newbie
  • *
  • Joined: Feb 2017
  • location: Seoul, Korea
  • Posts: 3
  • do you think that is the air, you're breathing now
  • Unit(s): Helix 10 mega si
  • Software: 1.350
  • Accessories: AS GPS HS
Re: During loading recording data into Humviewer, some error occurs.
« Reply #6 on: September 19, 2017, 05:25:56 PM »
The HB core series units do not have a dedicated DI channel transmitting to a DI piezo in the SI xducer  ...

The DI image is computer generated from the SI data into a format that "looks" like DI  ...

Therefore, there will be no SON file for DI (in the HB core series SI units)  ...

Rickie

For HDSI tranducer, you are right, there is no dedicated or physical channel for DI in Xducer.
But in MegaSI Xducer, there is physical DI channel.
( I have picture MEGA SI Xducer disassembled, but I don't know how to upload )

Following link is some Korean HB community, there is MEGASI Xducer which is disassembled.
« Last Edit: September 19, 2017, 05:29:23 PM by Mc Cloud »

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3088
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: During loading recording data into Humviewer, some error occurs.
« Reply #7 on: September 20, 2017, 08:59:51 AM »
For HDSI tranducer, you are right, there is no dedicated or physical channel for DI in Xducer.
But in MegaSI Xducer, there is physical DI channel.
( I have picture MEGA SI Xducer disassembled, but I don't know how to upload )

Following link is some Korean HB community, there is MEGASI Xducer which is disassembled.

You are correct and I should have differentiated the older core series units from New MEGA units having a dedicated DI channel  ...

I missed the OP designation his unit was MEGA  ...

Rickie
« Last Edit: September 21, 2017, 06:03:28 AM by rnvinc »

Offline ckd022

  • Newbie
  • *
  • Joined: Feb 2014
  • location: Chicago, IL
  • Posts: 18
  • Unit(s): 798ci SI Combo
  • Software: 5.840
Re: During loading recording data into Humviewer, some error occurs.
« Reply #8 on: September 20, 2017, 09:10:13 AM »
Given that there are both SI and a separate DI transducers on this particular unit, I'm back to wondering if that B004 is the new dedicated DI sonar data and that after B004 was deleted, Humviewer is showing the port SI data "rotated" to look like a down image.   

My guess is that Humviewer just keeps loading B00x files (incrementing x starting at 1) until it cannot find a file with that name, then it begins processing the data.  It obviously tried to read the B004 file when it was in the directory, but I'm guessing there was something in the format of the data that didn't "match" Humviewer's pre-programmed file types (since this transducer was created long after Humviewer stopped being updated).

Kevin


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
9 Replies
4339 Views
Last post December 28, 2009, 06:53:19 PM
by Crispen
14 Replies
4044 Views
Last post January 24, 2010, 07:00:52 AM
by George
0 Replies
1788 Views
Last post May 31, 2012, 02:29:15 PM
by Ricky
7 Replies
2152 Views
Last post January 25, 2013, 09:27:56 PM
by okiedokie
5 Replies
1775 Views
Last post May 09, 2013, 08:54:43 AM
by Yrral3215
18 Replies
5888 Views
Last post September 03, 2014, 06:59:11 PM
by Smellybox
6 Replies
808 Views
Last post August 05, 2016, 02:23:10 PM
by Scampbell
3 Replies
249 Views
Last post June 11, 2017, 05:12:16 PM
by fshndude


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal