Author Topic: Helix 9 Unit keeps shutting off when travelling through choppy waters  (Read 439 times)

0 Members and 1 Guest are viewing this topic.

Offline CSThao

  • Newbie
  • *
  • Joined: May 2016
  • location: Saint Paul, Minnesota
  • Posts: 2
  • Unit(s): Helix 9 SI
I was just wondering if anyone know a way to fix this issue? When I'm traveling through somewhat choppy water and it gets bumpy sometimes, then my unit powers off. I have my cords hot glued inside the bracket to keep the cords in place and not move around. It still doesn't help. Would I have to move the until to a different location to stabilize it more? I currently have it directly behind the steering wheel on the console.

Any advice would be appreciated.
« Last Edit: August 15, 2017, 08:54:34 PM by CSThao »


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3127
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Helix 9 Unit keeps shutting off when travelling through choppy waters
« Reply #1 on: August 16, 2017, 06:25:08 PM »
It's possible your intermittent power issue can be at the other end of the power circuit  ...

You should be able to recreate a loose connection issue by wiggling cables at connection points to track down which end of the power circuit is causing the intermittent connection  ...

Rickie

Offline CSThao

  • Newbie
  • *
  • Joined: May 2016
  • location: Saint Paul, Minnesota
  • Posts: 2
  • Unit(s): Helix 9 SI
Re: Helix 9 Unit keeps shutting off when travelling through choppy waters
« Reply #2 on: August 16, 2017, 07:00:23 PM »
I've checked all the cables, and it is the male / female end that connects to the unit. Wiggling the cables everywhere else and its fine, but wiggle the bracket and cord the power shuts off. The only solution i can think of is by probably trying to mount it somewhere else, which I'll have to try this weekend. 

Offline Bob B

  • Hero Member
  • *****
  • Joined: Oct 2010
  • location: Creve Coeur, Il
  • Posts: 1543
  • Unit(s): 1197c si, 1198c si
  • Software: 6.310, 6.490
Re: Helix 9 Unit keeps shutting off when travelling through choppy waters
« Reply #3 on: August 17, 2017, 08:44:02 AM »
Some have had success VERY SLIGHTLY tweaking the pins on the connector very slightly outward to improve the connection .... just be careful not to put enough pressure to bend the pins to much or break them.
**Looking for the one that makes it all worthwhile**

Offline baconstruction

  • Newbie
  • *
  • Joined: Aug 2017
  • location: wisconsin
  • Posts: 1
  • Unit(s): Helix 10
  • Software: 1.460
Re: Helix 9 Unit keeps shutting off when travelling through choppy waters
« Reply #4 on: September 10, 2017, 05:47:57 PM »
i had the same issue with my unit.  I removed the block that holds all the wires together and plugged them in directly and the problem went away.   I believe that block is too big and does not allow the wires to seat properly.  I covered the holes I am not using with clear tape for now but will come up with a better more waterproof fix soon


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
8 Replies
3410 Views
Last post August 20, 2010, 08:29:49 AM
by Humminbird_Greg
1 Replies
676 Views
Last post May 20, 2013, 09:49:41 AM
by Humminbird_Greg
4 Replies
1420 Views
Last post July 14, 2013, 05:42:22 PM
by KBarr
8 Replies
2143 Views
Last post March 20, 2014, 12:40:17 AM
by bully
17 Replies
5676 Views
Last post July 28, 2014, 09:16:00 AM
by Kevin Kromrey
0 Replies
779 Views
Last post July 18, 2015, 06:21:43 PM
by shanemcg83
3 Replies
462 Views
Last post April 17, 2017, 09:11:47 AM
by Bob B
1 Replies
332 Views
Last post August 16, 2017, 06:16:41 PM
by rnvinc


SimplePortal 2.3.3 © 2008-2010, SimplePortal