Author Topic: Wont turn on!  (Read 1998 times)

0 Members and 1 Guest are viewing this topic.

Offline JD88

  • Newbie
  • *
  • Joined: Sep 2013
  • location: United States
  • Posts: 8
  • Unit(s): 598
  • Software: Newest
  • Accessories: None
Wont turn on!
« on: August 22, 2014, 02:42:29 PM »
I've noticed last few trips the unit keeps shutting off on me and I figured I had a bad wire. Checked the wires and they were fine. Run power through a fuse as recommended and unit has always been babied. Only time it's on the boat is when it's in the water. Checked power at the battery 8.45v and at the unit power plug 8.45v..... Just tried calling and of course they closed up the minute I called. Anybody know of a fix or just have to send it in?


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3368
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: Wont turn on!
« Reply #1 on: August 22, 2014, 04:08:46 PM »
I've noticed last few trips the unit keeps shutting off on me and I figured I had a bad wire. Checked the wires and they were fine. Run power through a fuse as recommended and unit has always been babied. Only time it's on the boat is when it's in the water. Checked power at the battery 8.45v and at the unit power plug 8.45v..... Just tried calling and of course they closed up the minute I called. Anybody know of a fix or just have to send it in?

Is 8.45v a typo...??

That's way too low for the units...the manual says the unit needs 10-20v...

Can you have your battery load tested...?? (Auto parts stores will test this free)...

Rickie

Offline JD88

  • Newbie
  • *
  • Joined: Sep 2013
  • location: United States
  • Posts: 8
  • Unit(s): 598
  • Software: Newest
  • Accessories: None
Re: Wont turn on!
« Reply #2 on: August 24, 2014, 10:52:53 AM »
I didn't think my battery was that low but it could be. I'll try it again after charged before calling. I could have had the multi meter set wrong I don't know but does show that I was getting power to the plug. Thanks

Offline JD88

  • Newbie
  • *
  • Joined: Sep 2013
  • location: United States
  • Posts: 8
  • Unit(s): 598
  • Software: Newest
  • Accessories: None
Re: Wont turn on!
« Reply #3 on: August 25, 2014, 10:15:34 AM »
Apparently my battery was that low. Thanks!

Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: Wont turn on!
« Reply #4 on: August 25, 2014, 11:22:19 AM »
It could be damaged as well.  I would get it load tested so that you don't get stranded out on the water sometime.
Greg Walters at Humminbird
gwalters@johnsonoutdoors.com


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
4 Replies
2091 Views
Last post November 08, 2011, 08:16:36 AM
by Humminbird_Greg
9 Replies
5922 Views
Last post June 15, 2012, 03:37:54 PM
by jsiegle24
4 Replies
2139 Views
Last post April 17, 2013, 07:28:15 PM
by albe
6 Replies
2778 Views
Last post January 28, 2013, 04:18:05 PM
by Bob B
9 Replies
4720 Views
Last post March 23, 2014, 07:52:56 AM
by chuck41
8 Replies
6903 Views
Last post September 03, 2014, 12:09:29 PM
by Calcoast
1 Replies
943 Views
Last post April 21, 2015, 05:46:10 AM
by Humminbird_Greg
2 Replies
1088 Views
Last post November 23, 2016, 08:30:11 PM
by rickmbp


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal