Author Topic: cloudy on right side 598  (Read 2603 times)

0 Members and 1 Guest are viewing this topic.

Offline johnny miller

  • Newbie
  • *
  • Joined: Sep 2013
  • Posts: 5
  • Unit(s): 598 si
cloudy on right side 598
« on: September 15, 2013, 06:20:42 AM »
Why cloudy on right side


Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • location: Western KY
  • Posts: 3368
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Re: cloudy on right side 598
« Reply #1 on: September 15, 2013, 08:31:35 AM »
It looks like something may be blocking part of the right SI beam...

Can you post pix of your xducer install...??...from the rear, from the left, and from the right (at xducer level so we can see if something may be in the way...)

Rickie

Offline Humminbird_Greg

  • Humminbird Helper
  • Humminbird Staff
  • *
  • Joined: Mar 2009
  • location: Eufaula, AL.
  • Posts: 6546
  • I help because I can
    • Humminbird Web Site
Re: cloudy on right side 598
« Reply #2 on: September 16, 2013, 08:58:55 AM »
I’m thinking partial blockage of the right Si sonar combined with a failure of the right Si sonar beam…
Do you know anyone else with a Humminbird Si unit that would allow you to test your unit on their boat and their unit on your boat?  This would show us if the problem was in your unit or on your boat.  Any Humminbird Si model will work for the test even if you have to plug the unit in by hand and hold them there during the test.

Greg Walters at Humminbird
gwalters@johnsonoutdoors.com

Offline johnny miller

  • Newbie
  • *
  • Joined: Sep 2013
  • Posts: 5
  • Unit(s): 598 si
Re: cloudy on right side 598
« Reply #3 on: September 17, 2013, 06:38:27 AM »
I have this on my trolling motor so no blockage.  I have even remove the transducer as requested and held in water same problem.  I have adjusted angles on the trolling motor same issue.  I sent an email to hummingbird with the picture no response.  I am calling them for sending the new unit back in.  Bummer.  Have to remove and retread wires.  Bummer.  I have no one to hook up to and dont think that should have to be done.  I have read other threads this seems to be happening other peoples units. 


Thanks

Offline johnny miller

  • Newbie
  • *
  • Joined: Sep 2013
  • Posts: 5
  • Unit(s): 598 si
Re: cloudy on right side 598
« Reply #4 on: October 08, 2013, 11:33:33 AM »
Thought I would give a final update to my problem.  I received back my unit and transducer from Humminbird say unit has no problems.  I remounted with the same issues.  After 2 phone calls complaining of getting unit back without repair the nice Lady at humminbird sent out a new transducer.  She also assured me they would help if I had an issue.  Guess what?  It worked perfectly last night.  I am glad I keep visiting with the customer service.  Im glad they finally sent a new transducer out to me. 

Offline scylla

  • Newbie
  • *
  • Joined: Oct 2012
  • location: Australia
  • Posts: 4
  • Unit(s): 535
Re: cloudy on right side 598
« Reply #5 on: October 16, 2013, 03:11:19 AM »
Same issue for me on my 898 - transducer replaced by humminbird.  One run in deepish (30m of water) seems okay - but will see after a few more runs.

Offline johnny miller

  • Newbie
  • *
  • Joined: Sep 2013
  • Posts: 5
  • Unit(s): 598 si
Re: cloudy on right side 598
« Reply #6 on: October 16, 2013, 08:52:47 AM »
Mine has been working on last three runs.  I also bought the transducer saver thing which installed good.  I have noticed some haze still on right side but very little.  The Down immaging is working clearly now also as before I did not realize it was also cloudy until I got this new transducer installed.   I cant imagine them saying my unit was ok upon their lake run unless they simply did the test in like 5 feet of water.  But that being said Im glad that lady helped me out. 

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
1 Replies
1825 Views
Last post July 23, 2010, 02:18:21 PM
by RGecy
32 Replies
15118 Views
Last post February 22, 2011, 05:55:12 AM
by jules2003
13 Replies
7730 Views
Last post March 04, 2011, 02:00:00 PM
by sonar2000
12 Replies
3974 Views
Last post August 16, 2012, 12:14:39 PM
by ITGEEK
15 Replies
7855 Views
Last post October 15, 2012, 01:34:35 PM
by sonar2000
30 Replies
12359 Views
Last post March 25, 2013, 08:06:36 PM
by Bassgrabber
2 Replies
2440 Views
Last post May 21, 2013, 01:13:38 PM
by Humminbird_Greg
4 Replies
1173 Views
Last post June 24, 2016, 08:52:54 PM
by snooktarpon


SimplePortal 2.3.3 © 2008-2010, SimplePortal