Author Topic: Solved - Interference on Helix 10 SI Mega with Minn Kota Ulterra i-Pilot Link BT  (Read 6342 times)

0 Members and 1 Guest are viewing this topic.

Offline zip308

  • Newbie
  • *
  • Joined: Jun 2016
  • Location: MN
  • Posts: 5
  • Unit(s): Helix 10SI - Helix 9 - Helix 5 - 899SI
  • Software: new
  • Accessories: Networking - GPS w/HS
I have been experiencing interference on side imaging between my Helix 10 SI Mega whenever my Minn Kota Ulterra i-Pilot Link BT is running. The inference most visible on the high frequency 1.150-1.275 Mhz however it is present on the other side imaging frequencies.

Here is my current setup and the steps I had taken to trouble shoot the problem.

Helix 10 SI Mega G2N (console) with (2) XM 9 20 MSI T side imaging transducers w/MSILR Y and XNT 9 20 T high speed skimmer transducer w/MSIDB Y
Helix 10 Sonar G1 (console) networked to Helix 10 SI transducers
Helix 9 Sonar GPS G1 (bow) with US2 transducer
Ulterra i-Pilot Link BT
AS ETH 5PXG 5-port Ethernet switch
Trolling motor batteries separate from starting battery
All Helix power cables are run directly to the starting battery
Helix software 1.400 on all units
i-Pilot Link Controller V1.190
i-Pilot Link Remote V1.080
I have tried everything on Humminbird’s tech sheet other than drilling a hole in the trolling motor lower unit and running an external ground wire to the battery grounds. My understanding is that the US2 trolling motors have an internal ground wire from the motor housing up the shaft and grounded to the battery (US2 fuse in trolling motor head)
•   Turned off sonar from other Humminbird units
•   Disconnected other Humminbird units
•   Verified latest software versions on all units
•   Insured that all HB power cables are PC 11 with ferrite chokes
•   Installed ground wire from trolling motor battery to hull (may have reduced noise by 2%)
•   Tried a ground wire from trolling motor batter to cranking battery
•   Tried adjusting noise filters
•   Reset all units to factory defaults
•   Checked US2 fuse in trolling motor head
•   Checked all US2 connections
•   Removed 3-bank charger leads from all batteries
•   Installed HB 470085-1 ferrite rings around all transducer cables
•   Separated all Humminbird cables from trolling motor power cables
•   Hooked Helix 10 up to a separate local dedicated stand-alone battery

This is what I found to be the problem:
I disconnected all of the Ethernet cables from the AS ETH 5PXG 5-port switch and the interference went away. I then connected the Ethernet cable from the Ulterra directly to the Helix 10 SI Mega bypassing the AS ETH 5PXG switch and the interference immediately came back. This shows that the interference was traveling through the Ethernet cable of the Minn Kota Ulterra. I then grounded the metal barrel of Ethernet cable to the starting battery and the interference went away again. As a permanent solution, I added crimp-on terminal ring connector to one of the Ethernet posts on the AS ETH 5 PXG 5-port switch and grounded it to the negative of the starting battery.

NOTE: this will only relate to possible interference problems on Minn Kota i-Pilot Link trolling motors that have Ethernet cables connected to a Humminbird unit where the interference is traveling through the Ethernet cable itself and all of the other possible steps have been taken to reduce interference.

Offline rnvinc

  • Hero Member
  • *****
  • Joined: Nov 2009
  • Location: Western KY
  • Posts: 3588
  • Unit(s): 1197c SI Combo, Onix 8ci SI Combo
  • Software: Dependent on whim
  • Accessories: AS GRHA, AS GPS HS, LowBird LSS 1 & 2
Well now that's a new one on me  ...

Interesting  ...


Offline natestricksr

  • Newbie
  • *
  • Joined: Apr 2015
  • Location: Memphis
  • Posts: 3
  • Unit(s): 898 989
Interesting I have the problem on my ultrex i had the ulterra and no interference at all  I will definetly give it a shot!!

Offline sfw1960

  • Bringer Of The 'Bird
  • Sr. Member
  • ****
  • Joined: Jul 2010
  • Location: White Cloud , MI
  • Posts: 422
  • Unit(s): H10MSI G2N-H10MDI G2N-H12SI-H12MSI G2N
  • Software: v1.840 x 3, v1.830
  • Accessories: AS GPS HS x2, I-Pilot Link, RC-1, RC-2
Well now that's a new one on me  ...

Interesting  ...


That's RFI Rickie, that stuff can crawl out of nowhere and jump on & ride almost anywhere!

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo


Related Topics

  Subject / Started by Replies Last post
1 Replies
Last post September 10, 2010, 10:59:59 AM
by Humminbird_Greg
15 Replies
Last post April 23, 2013, 11:41:13 AM
by rocketman2008
3 Replies
Last post June 14, 2013, 07:27:05 AM
by bobcoy
7 Replies
Last post March 09, 2014, 11:08:49 AM
by bobcoy
1 Replies
Last post April 27, 2015, 11:44:03 AM
by Humminbird_Greg
2 Replies
Last post May 04, 2017, 10:14:53 PM
by burgersb
0 Replies
Last post July 02, 2017, 06:00:48 PM
by whizkids
6 Replies
Last post January 06, 2019, 02:05:37 PM
by rnvinc

SimplePortal 2.3.3 © 2008-2010, SimplePortal