Author Topic: Has anyone else had their screen go white? 798c SI HD  (Read 657 times)

0 Members and 1 Guest are viewing this topic.

Offline Mtnhick

  • Newbie
  • *
  • Joined: Feb 2012
  • location: Yorktown, va
  • Posts: 4
  • Unit(s): 79ci HD SI
  • Software: 6.570
Has anyone else had their screen go white? 798c SI HD
« on: May 01, 2017, 05:37:16 AM »
Hello All, I just wondering if anyone else has had this happen to them. the first time out this year my 798c SI HD was flickering a little when I first got on the water. Then the screen just went all white. I can hear it beep when I push the buttons and it acts like it should when you power it off, holding the power button for it to power off, but the screen is totally white, nothing shows up. I was wondering do I have a power issue, I have 2 mounting stations one on the bow and one on the stern and i have tried the both and it does the same thing in both places, or could it be that I have to update the software? Thanks for any and all advice with this problem. 


Offline sonar2000

  • Chief
  • Global Moderator
  • *
  • Joined: May 2009
  • location: Kerr Lake NC
  • Posts: 5970
  • It is not lost ...it has been misplaced.
  • Unit(s): (1) 1197 (1) 1198
  • Software: 6.6
  • Accessories: Tow Fish
Re: Has anyone else had their screen go white? 798c SI HD
« Reply #1 on: May 01, 2017, 06:08:43 AM »
Try checking the power supply first. And the connections. Especially if it has been sitting all winter..
Chuck

Offline N9Phil

  • Full Member
  • ***
  • Joined: Jan 2011
  • location: West Chicago, IL
  • Posts: 180
  • Unit(s): Solix 15 SI - Onix10 CI SI - 1198 CSI
  • Accessories: 80Terova W/ i-Link -- 360
Re: Has anyone else had their screen go white? 798c SI HD
« Reply #2 on: May 01, 2017, 11:45:38 AM »
When the screen goes white are you able to shut the unit off?   If you can get the unit off does the screen go white when is is first turned on. I would try to tap the unit and see if there is any flicker in the screen.  My first Onix would act up and if I taped it, it would go bad.  sent it in and they replaced the whole unit.
Solix 15 SI  Onix10 CI SI - 1198 CSIAccessories:80Terova W/ i-Link -- Transom 360


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
1165 Views
Last post May 23, 2011, 11:29:34 PM
by johno r
7 Replies
4203 Views
Last post July 01, 2011, 12:22:10 PM
by sonar2000
3 Replies
1512 Views
Last post April 13, 2012, 06:43:46 AM
by sonar2000
2 Replies
1693 Views
Last post November 14, 2013, 11:44:43 AM
by hgv
9 Replies
2671 Views
Last post May 07, 2014, 01:19:48 AM
by Tr-196
9 Replies
2206 Views
Last post January 25, 2015, 12:08:48 PM
by Bob B
5 Replies
1656 Views
Last post January 29, 2015, 01:06:47 PM
by Humminbird_Greg
3 Replies
979 Views
Last post June 18, 2015, 07:11:28 PM
by rnvinc


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal